22nd June 2020

Webmail Connectvity Issues impacting some users

Users using BT as their ISP may notice connectivity issues when accessing webmail -- Our Team have contacted BT and are awaiting a further update. We will provide further updates as we have more information, we apologise for any inconvenience caused.

Update: Our Team are still waiting for an update from BT, we'll continue to keep you updated.

Resolved: BT have removed the webmail URL from their blocked list after an 'incorrect categorisation' error, the update may take some time to take effect - Our sincere apologies for any inconvenience caused.